CVE-2016-5008

NameCVE-2016-5008
Descriptionlibvirt before 2.0.0 improperly disables password checking when the password on a VNC server is set to an empty string, which allows remote attackers to bypass authentication and establish a VNC session by connecting to the server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-541-1, DSA-3613-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvirt (PTS)wheezy0.9.12.3-1+deb7u1vulnerable
wheezy (security)0.9.12.3-1+deb7u2fixed
jessie1.2.9-9+deb8u4fixed
jessie (security)1.2.9-9+deb8u3fixed
stretch3.0.0-4fixed
stretch (security)3.0.0-4+deb9u1fixed
buster3.8.0-2fixed
sid3.8.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvirtsource(unstable)2.0.0-1medium
libvirtsourcejessie1.2.9-9+deb8u3mediumDSA-3613-1
libvirtsourcewheezy0.9.12.3-1+deb7u2mediumDLA-541-1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1180092
Fixed by: https://libvirt.org/git/?p=libvirt.git;a=commit;h=bb848feec0f3f10e92dd8e5231ae7aa89b5598f3 (v2.0.0)
Fixed by: https://libvirt.org/git/?p=libvirt.git;a=commit;h=f32441c69bf450d6ac593c3acd621c37e120cdaf (v1.2.9-maint)
http://security.libvirt.org/2016/0001.html

Search for package or bug name: Reporting problems