CVE-2016-5017

NameCVE-2016-5017
DescriptionBuffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and 3.5.x before 3.5.3, when using the "cmd:" batch mode syntax, allows attackers to have unspecified impact via a long command string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-630-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zookeeper (PTS)stretch (security), stretch3.4.9-3+deb9u2fixed
buster3.4.13-2fixed
bullseye, sid3.4.13-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zookeepersource(unstable)3.4.9-1
zookeepersourcejessie3.4.5+dfsg-2+deb8u1
zookeepersourcewheezy3.3.5+dfsg1-2+deb7u1DLA-630-1

Notes

The C cli shell is intended as a sample/example of how to use the C
client interface, not as a production tool
https://zookeeper.apache.org/security.html#CVE-2016-5017
Fixed by https://git-wip-us.apache.org/repos/asf?p=zookeeper.git;a=commitdiff;h=27ecf981a15554dc8e64a28630af7a5c9e2bdf4f

Search for package or bug name: Reporting problems