CVE-2016-5095

NameCVE-2016-5095
DescriptionInteger overflow in the php_escape_html_entities_ex function in ext/standard/html.c in PHP before 5.5.36 and 5.6.x before 5.6.22 allows remote attackers to cause a denial of service or possibly have unspecified other impact by triggering a large output string from a FILTER_SANITIZE_FULL_SPECIAL_CHARS filter_var call. NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-5094.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-533-1, DSA-3602-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.6.22+dfsg-1high
php5sourcejessie5.6.22+dfsg-0+deb8u1highDSA-3602-1
php5sourcewheezy5.4.45-0+deb7u4highDLA-533-1

Notes

PHP bug: https://bugs.php.net/bug.php?id=72135
Fixed in 5.6.22, 5.5.36
http://www.openwall.com/lists/oss-security/2016/05/25/3
For the additional issue reported in the "[2016-05-17 12:55 UTC]" comment

Search for package or bug name: Reporting problems