CVE-2016-5096

NameCVE-2016-5096
DescriptionInteger overflow in the fread function in ext/standard/file.c in PHP before 5.5.36 and 5.6.x before 5.6.22 allows remote attackers to cause a denial of service or possibly have unspecified other impact via a large integer in the second argument.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-533-1, DSA-3602-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.6.22+dfsg-1high
php5sourcejessie5.6.22+dfsg-0+deb8u1highDSA-3602-1
php5sourcewheezy5.4.45-0+deb7u4highDLA-533-1

Notes

PHP bug: https://bugs.php.net/bug.php?id=72114
Fixed in 5.6.22, 5.5.36
http://www.openwall.com/lists/oss-security/2016/05/25/3

Search for package or bug name: Reporting problems