CVE-2016-5108

NameCVE-2016-5108
DescriptionBuffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media player before 2.2.4 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted QuickTime IMA file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3598-1
NVD severityhigh (attack range: remote)
Debian Bugs825728

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)wheezy, wheezy (security)2.0.3-5+deb7u2vulnerable
jessie (security), jessie2.2.6-1~deb8u1fixed
stretch2.2.6-1~deb9u1fixed
buster, sid2.2.6-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)2.2.3-2high825728
vlcsourcejessie2.2.4-1~deb8u1highDSA-3598-1
vlcsourcewheezy(unfixed)end-of-life

Notes

[wheezy] - vlc <end-of-life> (Unsupported in wheezy-lts)
Details: http://www.openwall.com/lists/oss-security/2016/05/27/3
https://git.videolan.org/?p=vlc.git;a=commit;h=458ed62bbeb9d1bddf7b8df104e14936408a3db9

Search for package or bug name: Reporting problems