CVE-2016-5114

NameCVE-2016-5114
Descriptionsapi/fpm/fpm/fpm_log.c in PHP before 5.5.31, 5.6.x before 5.6.17, and 7.x before 7.0.2 misinterprets the semantics of the snprintf return value, which allows attackers to obtain sensitive information from process memory or cause a denial of service (out-of-bounds read and buffer overflow) via a long string, as demonstrated by a long URI in a configuration with custom REQUEST_URI logging.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-628-1
NVD severitymedium

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5sourcesqueeze(not affected)
php5sourcewheezy5.4.45-0+deb7u5DLA-628-1
php5sourcejessie5.6.17+dfsg-0+deb8u1
php5source(unstable)5.6.17+dfsg-1

Notes

[squeeze] - php5 <not-affected> (vulnerable code not present)
https://bugs.php.net/bug.php?id=70755
https://git.php.net/?p=php-src.git;a=commit;h=2721a0148649e07ed74468f097a28899741eb58f
http://seclists.org/bugtraq/2016/Jan/117
https://www.openwall.com/lists/oss-security/2016/02/02/4

Search for package or bug name: Reporting problems