CVE-2016-5240

NameCVE-2016-5240
DescriptionThe DrawDashPolygon function in magick/render.c in GraphicsMagick before 1.3.24 and the SVG renderer in ImageMagick allow remote attackers to cause a denial of service (infinite loop) by converting a circularly defined SVG file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-547-1, DSA-3746-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)stretch1.3.30+hg15796-1~deb9u2fixed
stretch (security)1.3.30+hg15796-1~deb9u4fixed
buster1.4~hg15978-1+deb10u1fixed
buster (security)1.4+really1.3.35-1~deb10u1fixed
bullseye, sid1.4+really1.3.35+hg16297-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.24-1
graphicsmagicksourcejessie1.3.20-3+deb8u2DSA-3746-1
graphicsmagicksourcewheezy1.3.16-1.1+deb7u3DLA-547-1

Notes

Fixed by: http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/ddc999ec896c
DLA-547-1 didn't fix this properly

Search for package or bug name: Reporting problems