CVE-2016-5257

NameCVE-2016-5257
DescriptionMultiple unspecified vulnerabilities in the browser engine in Mozilla Firefox before 49.0 and Firefox ESR 45.x before 45.4 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via unknown vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-636-1, DLA-658-1, DSA-3674-1, DSA-3690-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid57.0.1-1fixed
firefox-esr (PTS)wheezy (security)52.5.2esr-1~deb7u1fixed
jessie (security), jessie52.5.0esr-1~deb8u1fixed
stretch52.5.0esr-1~deb9u1fixed
stretch (security)52.5.2esr-1~deb9u1fixed
buster52.5.0esr-1fixed
sid52.5.2esr-1fixed
icedove (PTS)wheezy38.7.0-1~deb7u1vulnerable
wheezy (security)1:52.3.0-4~deb7u2fixed
jessie1:45.8.0-3~deb8u1fixed
jessie (security)1:52.3.0-4~deb8u2fixed
stretch (security), stretch1:52.3.0-4~deb9u1fixed
sid1:52.3.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)49.0-1high
firefox-esrsource(unstable)45.4.0esr-1high
firefox-esrsourcejessie45.4.0esr-1~deb8u2highDSA-3674-1
firefox-esrsourcewheezy45.4.0esr-1~deb7u1highDLA-636-1
icedovesource(unstable)1:45.4.0-1high
icedovesourcejessie1:45.4.0-1~deb8u1highDSA-3690-1
icedovesourcewheezy1:45.4.0-1~deb7u1highDLA-658-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2016-85/
https://www.mozilla.org/en-US/security/advisories/mfsa2016-86/

Search for package or bug name: Reporting problems