CVE-2016-5261

NameCVE-2016-5261
DescriptionInteger overflow in the WebSocketChannel class in the WebSockets subsystem in Mozilla Firefox before 48.0 and Firefox ESR < 45.4 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via crafted packets that trigger incorrect buffer-resize operations during buffering.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-636-1, DSA-3674-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid78.0.1-1fixed
firefox-esr (PTS)stretch68.4.1esr-1~deb9u1fixed
stretch (security)68.10.0esr-1~deb9u1fixed
buster68.7.0esr-1~deb10u1fixed
buster (security)68.10.0esr-1~deb10u1fixed
bullseye, sid68.10.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)48.0-1
firefox-esrsource(unstable)45.4.0esr-1
firefox-esrsourcejessie45.4.0esr-1~deb8u2DSA-3674-1
firefox-esrsourcewheezy45.4.0esr-1~deb7u1DLA-636-1

Notes

For Firefox: https://www.mozilla.org/en-US/security/advisories/mfsa2016-75/
For Firefox https://www.mozilla.org/security/advisories/mfsa2016-86/

Search for package or bug name: Reporting problems