CVE-2016-5297

NameCVE-2016-5297
DescriptionAn error in argument length checking in JavaScript, leading to potential integer overflows or other bounds checking issues. This vulnerability affects Thunderbird < 45.5, Firefox ESR < 45.5, and Firefox < 50.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-730-1, DLA-752-1, DSA-3716-1, DSA-3730-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid61.0-2fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1fixed
jessie (security)52.9.0esr-1~deb8u1fixed
stretch (security), stretch52.9.0esr-1~deb9u1fixed
buster, sid52.9.0esr-1fixed
icedove (PTS)jessie (security), jessie1:52.3.0-4~deb8u2fixed
stretch (security)1:52.3.0-4~deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)50.0-1
firefox-esrsource(unstable)45.5.0esr-1
firefox-esrsourcejessie45.5.0esr-1~deb8u1DSA-3716-1
firefox-esrsourcewheezy45.5.1esr-1~deb7u1DLA-730-1
icedovesource(unstable)1:45.5.0-1
icedovesourcejessie1:45.5.1-1~deb8u1DSA-3730-1
icedovesourcewheezy1:45.5.1-1~deb7u1DLA-752-1

Search for package or bug name: Reporting problems