CVE-2016-5317

NameCVE-2016-5317
DescriptionBuffer overflow in the PixarLogDecode function in libtiff.so in the PixarLogDecode function in libtiff 4.0.6 and earlier, as used in GNOME nautilus, allows attackers to cause a denial of service attack (crash) via a crafted TIFF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-606-1, DLA-610-1, DSA-3762-1
NVD severitymedium (attack range: remote)
Debian Bugs830700

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)wheezy4.0.2-6+deb7u5vulnerable
wheezy (security)4.0.2-6+deb7u17fixed
jessie (security), jessie4.0.3-12.3+deb8u4fixed
stretch (security), stretch4.0.8-2+deb9u1fixed
buster, sid4.0.9-1fixed
tiff3 (PTS)wheezy3.9.6-11vulnerable
wheezy (security)3.9.6-11+deb7u8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)4.0.6-2medium830700
tiffsourcejessie4.0.3-12.3+deb8u2mediumDSA-3762-1
tiffsourcewheezy4.0.2-6+deb7u6mediumDLA-606-1
tiff3source(unstable)(unfixed)medium
tiff3sourcewheezy3.9.6-11+deb7u1mediumDLA-610-1

Notes

http://bugzilla.maptools.org/show_bug.cgi?id=2557
Reproducer http://bugzilla.maptools.org/attachment.cgi?id=653
Upstream marked this duplicate of bug http://bugzilla.maptools.org/show_bug.cgi?id=2554

Search for package or bug name: Reporting problems