CVE-2016-5338

NameCVE-2016-5338
DescriptionThe (1) esp_reg_read and (2) esp_reg_write functions in hw/scsi/esp.c in QEMU allow local guest OS administrators to cause a denial of service (QEMU process crash) or execute arbitrary code on the QEMU host via vectors related to the information transfer buffer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1599-1
NVD severitymedium
Debian Bugs827024

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)stretch1:2.8+dfsg-6+deb9u9fixed
stretch (security)1:2.8+dfsg-6+deb9u16fixed
buster, buster (security)1:3.1+dfsg-8+deb10u8fixed
bullseye1:5.2+dfsg-11fixed
bookworm, sid1:6.1+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcejessie1:2.1+dfsg-12+deb8u8DLA-1599-1
qemusource(unstable)1:2.6+dfsg-2827024
qemu-kvmsource(unstable)(unfixed)

Notes

[wheezy] - qemu <no-dsa> (Minor issue)
[wheezy] - qemu-kvm <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1343323
https://lists.gnu.org/archive/html/qemu-devel/2016-06/msg01507.html
http://git.qemu.org/?p=qemu.git;a=commit;h=ff589551c8e8e9e95e211b9d8daafb4ed39f1aec

Search for package or bug name: Reporting problems