CVE-2016-5351

NameCVE-2016-5351
Descriptionepan/crypt/airpdcap.c in the IEEE 802.11 dissector in Wireshark 1.12.x before 1.12.12 and 2.x before 2.0.4 mishandles the lack of an EAPOL_RSN_KEY, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-538-1, DSA-3615-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)buster2.6.20-0+deb10u4fixed
buster (security)2.6.20-0+deb10u2fixed
bullseye (security), bullseye3.4.10-0+deb11u1fixed
bookworm, sid3.6.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourcewheezy1.12.1+g01b65bf-4+deb8u6~deb7u2DLA-538-1
wiresharksourcejessie1.12.1+g01b65bf-4+deb8u7DSA-3615-1
wiresharksource(unstable)2.0.4+gdd7746e-1

Notes

https://www.wireshark.org/security/wnpa-sec-2016-30.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=11585
https://github.com/wireshark/wireshark/commit/9b0b20b8d5f8c9f7839d58ff6c5900f7e19283b4

Search for package or bug name: Reporting problems