DescriptionApache Tomcat 7.x through 7.0.70 and 8.x through 8.5.4, when the CGI Servlet is enabled, follows RFC 3875 section 4.1.18 and therefore does not protect applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, aka an "httpoxy" issue. NOTE: the vendor states "A mitigation is planned for future releases of Tomcat, tracked as CVE-2016-5388"; in other words, this is not a CVE ID for a vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs802312

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat6 (PTS)wheezy6.0.45+dfsg-1~deb7u1fixed
wheezy (security)6.0.45+dfsg-1~deb7u5fixed
jessie (security), jessie6.0.45+dfsg-1~deb8u1fixed
tomcat7 (PTS)wheezy7.0.28-4+deb7u4vulnerable
wheezy (security)7.0.28-4+deb7u18vulnerable
jessie (security), jessie7.0.56-3+deb8u11vulnerable
buster, sid7.0.78-1fixed
tomcat8 (PTS)jessie (security), jessie8.0.14-1+deb8u11vulnerable
stretch (security), stretch8.5.14-1+deb9u2fixed
buster, sid8.5.29-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


Since 6.0.41-3, src:tomcat6 only builds a servlet and docs
No part of Tomcat does set HTTP_PROXY based on a Proxy: header, upstream plans
some hardening to discard HTTP_PROXY in the future
This CVE was special since not assigned to a vulnerability but for a mitigation
thus marking as fixed for 8.0.37 and 7.0.71 (upstream) and with according
versions in Debian. (8.0.x) (7.0.x)

Search for package or bug name: Reporting problems