CVE-2016-5407

NameCVE-2016-5407
DescriptionThe (1) XvQueryAdaptors and (2) XvQueryEncodings functions in X.org libXv before 1.0.11 allow remote X servers to trigger out-of-bounds memory access operations via vectors involving length specifications in received data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-667-1
NVD severityhigh (attack range: remote)
Debian Bugs840438

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxv (PTS)wheezy2:1.0.7-1+deb7u1vulnerable
wheezy (security)2:1.0.7-1+deb7u2fixed
jessie2:1.0.10-1vulnerable
buster, sid, stretch2:1.0.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxvsource(unstable)2:1.0.11-1low840438
libxvsourcewheezy2:1.0.7-1+deb7u2highDLA-667-1

Notes

[jessie] - libxv <no-dsa> (Minor issue, will be fixed in a point release)
https://cgit.freedesktop.org/xorg/lib/libXv/commit/?id=d9da580b46a28ab497de2e94fdc7b9ff953dab17

Search for package or bug name: Reporting problems