DescriptionStack-based buffer overflow in the munge_other_line function in cachemgr.cgi in the squid package before 3.1.23-16.el6_8.6 in Red Hat Enterprise Linux 6 allows remote attackers to execute arbitrary code via unspecified vectors. NOTE: this vulnerability exists because of an incorrect fix for CVE-2016-4051.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid3 (PTS)wheezy3.1.20-2.2+deb7u4vulnerable
wheezy (security)3.1.20-2.2+deb7u8fixed
jessie (security)3.4.8-6+deb8u5fixed
stretch (security), stretch3.5.23-5+deb9u1fixed
buster, sid3.5.27-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squid3source(unstable)(not affected)


- squid3 <not-affected> (Incomplete fix for CVE-2016-4051 not applied)
CVE is specific for the incomplete fix of CVE-2016-4051 as applied
by some vendors.

Search for package or bug name: Reporting problems