CVE-2016-5419

NameCVE-2016-5419
Descriptioncurl and libcurl before 7.50.1 do not prevent TLS session resumption when the client certificate has changed, which allows remote attackers to bypass intended restrictions by resuming a session.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-586-1, DSA-3638-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)stretch7.52.1-5+deb9u10fixed
stretch (security)7.52.1-5+deb9u12fixed
buster, buster (security)7.64.0-4+deb10u1fixed
bullseye, sid7.72.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcewheezy7.26.0-1+wheezy14DLA-586-1
curlsourcejessie7.38.0-4+deb8u4DSA-3638-1
curlsource(unstable)7.50.1-1

Notes

https://curl.haxx.se/docs/adv_20160803A.html
Fixed by https://curl.haxx.se/CVE-2016-5419.patch
Wheezy: vulnerable code is in lib/sslgen.c

Search for package or bug name: Reporting problems