CVE-2016-5420

NameCVE-2016-5420
Descriptioncurl and libcurl before 7.50.1 do not check the client certificate when choosing the TLS connection to reuse, which might allow remote attackers to hijack the authentication of the connection by leveraging a previously created connection with a different client certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-586-1, DSA-3638-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)wheezy7.26.0-1+wheezy13vulnerable
wheezy (security)7.26.0-1+wheezy25fixed
jessie7.38.0-4+deb8u8fixed
jessie (security)7.38.0-4+deb8u10fixed
stretch7.52.1-5+deb9u4fixed
stretch (security)7.52.1-5+deb9u5fixed
buster, sid7.58.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.50.1-1medium
curlsourcejessie7.38.0-4+deb8u4mediumDSA-3638-1
curlsourcewheezy7.26.0-1+wheezy14mediumDLA-586-1

Notes

https://curl.haxx.se/docs/adv_20160803B.html
Fixed by https://curl.haxx.se/CVE-2016-5420.patch
Wheezy: vulnerable code is in lib/sslgen.c

Search for package or bug name: Reporting problems