CVE-2016-5421

NameCVE-2016-5421
DescriptionUse-after-free vulnerability in libcurl before 7.50.1 allows attackers to control which connection is used or possibly have unspecified other impact via unknown vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3638-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)bullseye7.74.0-1.3+deb11u12fixed
bullseye (security)7.74.0-1.3+deb11u11fixed
bookworm7.88.1-10+deb12u6fixed
bookworm (security)7.88.1-10+deb12u5fixed
sid, trixie8.8.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcewheezy(not affected)
curlsourcejessie7.38.0-4+deb8u4DSA-3638-1
curlsource(unstable)7.50.1-1

Notes

[wheezy] - curl <not-affected> (introduced in 7.32.0)
https://curl.haxx.se/docs/adv_20160803C.html
Fixed by https://curl.haxx.se/CVE-2016-5421.patch

Search for package or bug name: Reporting problems