CVE-2016-5426

NameCVE-2016-5426
DescriptionPowerDNS (aka pdns) Authoritative Server before 3.4.10 allows remote attackers to cause a denial of service (backend CPU consumption) via a long qname.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-627-1, DSA-3664-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)wheezy3.1-4.1vulnerable
wheezy (security)3.1-4.1+deb7u3fixed
jessie (security), jessie3.4.1-4+deb8u7fixed
stretch4.0.3-1fixed
buster, sid4.0.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdnssource(unstable)4.0.0~alpha1-1medium
pdnssourcejessie3.4.1-4+deb8u6mediumDSA-3664-1
pdnssourcewheezy3.1-4.1+deb7u2mediumDLA-627-1

Notes

Only affects PowerDNS Authoritative Server up to and including 3.4.9, 4.x not affected
Added workaround to mark first 4.x version in unstable as fixed.
https://doc.powerdns.com/md/security/powerdns-advisory-2016-01/
https://github.com/PowerDNS/pdns/commit/881b5b03a590198d03008e4200dd00cc537712f3

Search for package or bug name: Reporting problems