CVE-2016-5598

NameCVE-2016-5598
DescriptionUnspecified vulnerability in the MySQL Connector component 2.1.3 and earlier and 2.0.4 and earlier in Oracle MySQL allows remote attackers to affect confidentiality, integrity, and availability via vectors related to Connector/Python.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs841677

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mysql-connector-python (PTS)stretch2.1.6-1fixed
sid8.0.15-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mysql-connector-pythonsourcewheezy(not affected)
mysql-connector-pythonsourcejessie(not affected)
mysql-connector-pythonsource(unstable)2.1.5-1841677

Notes

[jessie] - mysql-connector-python <not-affected> (Vulnerable code not present)
[wheezy] - mysql-connector-python <not-affected> (Only the Python 3 code is affected which is not shipped in binary package)
https://blog.qualys.com/laws-of-vulnerabilities/2016/10/18/oracle-october-2016-critical-patch-update

Search for package or bug name: Reporting problems