CVE-2016-5687

NameCVE-2016-5687
DescriptionThe VerticalFilter function in the DDS coder in ImageMagick before 6.9.4-3 and 7.x before 7.0.1-4 allows remote attackers to have unspecified impact via a crafted DDS file, which triggers an out-of-bounds read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-731-1, DSA-3652-1
NVD severityhigh (attack range: remote)
Debian Bugs832890

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4vulnerable
wheezy (security)8:6.7.7.10-5+deb7u18fixed
jessie (security), jessie8:6.8.9.9-5+deb8u11fixed
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u3fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.6.2+dfsg-2high832890
imagemagicksourcejessie8:6.8.9.9-5+deb8u4highDSA-3652-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u8highDLA-731-1

Notes

https://blog.fuzzing-project.org/46-Various-invalid-memory-reads-in-ImageMagick-WPG,-DDS,-DCM.html
https://github.com/ImageMagick/ImageMagick/commit/0b7172f2ba2c9e664d4df148e7d6e14a50edb57a

Search for package or bug name: Reporting problems