CVE-2016-5697

NameCVE-2016-5697
DescriptionRuby-saml before 1.3.0 allows attackers to perform XML signature wrapping attacks via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs828076

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-saml (PTS)stretch1.4.1-1fixed
buster1.7.2-1fixed
bullseye, sid1.11.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-samlsource(unstable)1.3.0-1828076

Notes

https://github.com/onelogin/ruby-saml/commit/a571f52171e6bfd87db59822d1d9e8c38fb3b995

Search for package or bug name: Reporting problems