DescriptionPuppet Enterprise 2015.3.3 and 2016.x before 2016.4.0, and Puppet Agent 1.3.6 through 1.7.0 allow remote attackers to bypass a host whitelist protection mechanism and execute arbitrary code on Puppet nodes via vectors related to command validation, aka "Puppet Execution Protocol (PXP) Command Whitelist Validation Vulnerability."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet (PTS)bullseye5.5.22-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puppetsourcewheezy(not affected)
puppetsourcejessie(not affected)


[jessie] - puppet <not-affected> (Vulnerable code introduced later)
[wheezy] - puppet <not-affected> (Vulnerable code introduced later)
triaged away in Ubuntu: "Default configurations of FOSS Puppet Agent are not vulnerable."
gentoo released a fix:
rosetta stone for puppet version numbers:

Search for package or bug name: Reporting problems