CVE-2016-5714

NameCVE-2016-5714
DescriptionPuppet Enterprise 2015.3.3 and 2016.x before 2016.4.0, and Puppet Agent 1.3.6 through 1.7.0 allow remote attackers to bypass a host whitelist protection mechanism and execute arbitrary code on Puppet nodes via vectors related to command validation, aka "Puppet Execution Protocol (PXP) Command Whitelist Validation Vulnerability."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet (PTS)jessie (security), jessie3.7.2-4+deb8u1fixed
stretch4.8.2-5fixed
bullseye, sid, buster5.5.10-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puppetsource(unstable)4.8.0-1medium
puppetsourcejessie(not affected)
puppetsourcewheezy(not affected)

Notes

[jessie] - puppet <not-affected> (Vulnerable code introduced later)
[wheezy] - puppet <not-affected> (Vulnerable code introduced later)
https://puppet.com/security/cve/pxp-agent-oct-2016
triaged away in Ubuntu: "Default configurations of FOSS Puppet Agent are not vulnerable."
gentoo released a fix: https://security.gentoo.org/glsa/201710-12
rosetta stone for puppet version numbers: https://puppet.com/docs/puppet/4.10/about_agent.html

Search for package or bug name: Reporting problems