CVE-2016-5767

NameCVE-2016-5767
DescriptionInteger overflow in the gdImageCreate function in gd.c in the GD Graphics Library (aka libgd) before 2.0.34RC1, as used in PHP before 5.5.37, 5.6.x before 5.6.23, and 7.x before 7.0.8, allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted image dimensions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)jessie (security), jessie2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-4fixed
php5 (PTS)jessie5.6.33+dfsg-0+deb8u1fixed
jessie (security)5.6.36+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch (security), stretch7.0.30-0+deb9u1fixed
sid7.0.30-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.0.34~rc1-1medium
php5source(unstable)5.6.23+dfsg-1unimportant
php5sourcejessie5.6.23+dfsg-0+deb8u1medium
php7.0source(unstable)7.0.8-1unimportant

Notes

Starting with 5.4.0-1 Debian uses the system copy of libgd
PHP Bug: https://bugs.php.net/bug.php?id=72446
http://git.php.net/?p=php-src.git;a=commitdiff;h=c395c6e5d7e8df37a21265ff76e48fe75ceb5ae6
Fixed in 5.5.37, 5.6.23, 7.0.8
Fixed by: https://github.com/libgd/libgd/commit/cfee163a5e848fc3e3fb1d05a30d7557cdd36457 (GD_2_0_34RC1)

Search for package or bug name: Reporting problems