CVE-2016-5829

NameCVE-2016-5829
DescriptionMultiple heap-based buffer overflows in the hiddev_ioctl_usage function in drivers/hid/usbhid/hiddev.c in the Linux kernel through 4.6.3 allow local users to cause a denial of service or possibly have unspecified other impact via a crafted (1) HIDIOCGUSAGES or (2) HIDIOCSUSAGES ioctl call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-609-1, DSA-3616-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1vulnerable
wheezy (security)3.2.93-1fixed
jessie3.16.43-2+deb8u2fixed
jessie (security)3.16.43-2+deb8u5fixed
stretch4.9.51-1fixed
stretch (security)4.9.30-2+deb9u5fixed
buster, sid4.13.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.6.3-1high
linuxsourcejessie3.16.7-ckt25-2+deb8u3highDSA-3616-1
linuxsourcewheezy3.2.81-2highDLA-609-1

Notes

Fixed by: https://git.kernel.org/linus/93a2001bdfd5376c3dc2158653034c20392d15c5

Search for package or bug name: Reporting problems