CVE-2016-5834

NameCVE-2016-5834
DescriptionCross-site scripting (XSS) vulnerability in the wp_get_attachment_link function in wp-includes/post-template.php in WordPress before 4.5.3 allows remote attackers to inject arbitrary web script or HTML via a crafted attachment name, a different vulnerability than CVE-2016-5833.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-568-1, DSA-3639-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17fixed
jessie (security)4.1.28+dfsg-0+deb8u1fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u5fixed
buster5.0.4+dfsg1-1fixed
bullseye, sid5.2.4+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.5.3+dfsg-1
wordpresssourcejessie4.1+dfsg-1+deb8u9DSA-3639-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u11DLA-568-1

Notes

https://wordpress.org/news/2016/06/wordpress-4-5-3/
https://core.trac.wordpress.org/changeset/37790/

Search for package or bug name: Reporting problems