CVE-2016-5844

NameCVE-2016-5844
DescriptionInteger overflow in the ISO parser in libarchive before 3.2.1 allows remote attackers to cause a denial of service (application crash) via a crafted ISO file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-554-1, DSA-3657-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libarchive (PTS)wheezy3.0.4-3+wheezy1vulnerable
wheezy (security)3.0.4-3+wheezy6+deb7u1fixed
jessie (security), jessie3.1.2-11+deb8u3fixed
stretch3.2.2-2fixed
buster, sid3.2.2-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libarchivesource(unstable)3.2.1-1medium
libarchivesourcejessie3.1.2-11+deb8u2mediumDSA-3657-1
libarchivesourcewheezy3.0.4-3+wheezy2mediumDLA-554-1

Notes

Upstream ticket: https://github.com/libarchive/libarchive/issues/717
Upstream fix: https://github.com/libarchive/libarchive/commit/3ad08e01b4d253c66ae56414886089684155af22 (v3.2.1)

Search for package or bug name: Reporting problems