CVE-2016-5873

NameCVE-2016-5873
DescriptionBuffer overflow in the HTTP URL parsing functions in pecl_http before 3.0.1 might allow remote attackers to execute arbitrary code via non-printable characters in a URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-pecl-http (PTS)buster3.2.0+2.6.0-2fixed
bullseye4.0.0+3.2.4+2.6.0-0+deb11u1fixed
bookworm, sid4.2.3-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-pecl-httpsourcejessie(not affected)
php-pecl-httpsource(unstable)3.0.1-0.1

Notes

[jessie] - php-pecl-http <not-affected> (Vulnerable code not present)
https://bugs.php.net/bug.php?id=71719
https://github.com/m6w6/ext-http/commit/3724cd76a28be1d6049b5537232e97ac567ae1f5/def

Search for package or bug name: Reporting problems