CVE-2016-6171

NameCVE-2016-6171
DescriptionKnot DNS before 2.3.0 allows remote DNS servers to cause a denial of service (memory exhaustion and slave server crash) via a large zone transfer for (1) DDNS, (2) AXFR, or (3) IXFR.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs830809

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
knot (PTS)jessie (security), jessie1.6.0-1+deb8u1vulnerable
stretch (security), stretch2.4.0-3+deb9u1fixed
buster, sid2.7.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
knotsource(unstable)2.3.0-1medium830809

Notes

[jessie] - knot <no-dsa> (Minor issue)
https://gitlab.labs.nic.cz/labs/knot/merge_requests/541
https://gitlab.labs.nic.cz/labs/knot/issues/464

Search for package or bug name: Reporting problems