CVE-2016-6175

NameCVE-2016-6175
DescriptionEval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute arbitrary PHP code via a crafted plural forms header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs851771

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-gettext (PTS)wheezy, jessie1.0.11-1vulnerable
buster, sid, stretch1.0.12-0.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-gettextsource(unstable)(unfixed)high851771

Notes

[stretch] - php-gettext <no-dsa> (Minor issue)
[jessie] - php-gettext <no-dsa> (Minor issue)
[wheezy] - php-gettext <no-dsa> (Minor issue)
https://bugs.launchpad.net/php-gettext/+bug/1606184
https://kmkz-web-blog.blogspot.cz/2016/07/advisory-cve-2016-6175.html

Search for package or bug name: Reporting problems