CVE-2016-6186

NameCVE-2016-6186
DescriptionCross-site scripting (XSS) vulnerability in the dismissChangeRelatedObjectPopup function in contrib/admin/static/admin/js/admin/RelatedObjectLookups.js in Django before 1.8.14, 1.9.x before 1.9.8, and 1.10.x before 1.10rc1 allows remote attackers to inject arbitrary web script or HTML via vectors involving unsafe usage of Element.innerHTML.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-555-1, DSA-3622-1
NVD severitymedium (attack range: remote)
Debian Bugs831799

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)wheezy1.4.5-1+deb7u16vulnerable
wheezy (security)1.4.22-1+deb7u3fixed
jessie (security), jessie1.7.11-1+deb8u2fixed
stretch1:1.10.7-2fixed
buster, sid1:1.11.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosource(unstable)1:1.9.8-1medium831799
python-djangosourcejessie1.7.7-1+deb8u5mediumDSA-3622-1
python-djangosourcewheezy1.4.5-1+deb7u17mediumDLA-555-1

Notes

https://www.djangoproject.com/weblog/2016/jul/18/security-releases/

Search for package or bug name: Reporting problems