CVE-2016-6211

NameCVE-2016-6211
DescriptionThe User module in Drupal 7.x before 7.44 allows remote authenticated users to gain privileges via vectors involving contributed or custom code that triggers a rebuild of the user profile form.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-550-1, DSA-3604-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal7 (PTS)wheezy7.14-2+deb7u12vulnerable
wheezy (security)7.14-2+deb7u16fixed
jessie (security), jessie7.32-1+deb8u9fixed
stretch (security), stretch7.52-2+deb9u1fixed
buster, sid7.56-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal7source(unstable)7.44-1medium
drupal7sourcejessie7.32-1+deb8u7mediumDSA-3604-1
drupal7sourcewheezy7.14-2+deb7u14mediumDLA-550-1

Notes

https://www.drupal.org/SA-CORE-2016-002
http://www.openwall.com/lists/oss-security/2016/07/13/4
https://gist.github.com/lamby/4697fea399f3f01ca6de3ce9ed79fce7 tarball diff
https://gist.github.com/lamby/dbeda4d49f48a32aa0dd4b3ed7f06a13 filtered diff

Search for package or bug name: Reporting problems