CVE-2016-6232

NameCVE-2016-6232
DescriptionDirectory traversal vulnerability in KArchive before 5.24, as used in KDE Frameworks, allows remote attackers to write to arbitrary files via a ../ (dot dot slash) in a filename in an archive file, related to KNewsstuff downloads.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-570-1, DSA-3643-1
NVD severitymedium (attack range: remote)
Debian Bugs832620

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
karchive (PTS)stretch5.28.0-2fixed
buster, sid5.37.0-2fixed
kde4libs (PTS)wheezy4:4.8.4-4+deb7u1vulnerable
wheezy (security)4:4.8.4-4+deb7u3fixed
jessie (security), jessie4:4.14.2-5+deb8u2fixed
stretch4:4.14.26-2fixed
buster, sid4:4.14.36-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
karchivesource(unstable)5.24.0-1medium
kde4libssource(unstable)4:4.14.22-2medium832620
kde4libssourcejessie4:4.14.2-5+deb8u1mediumDSA-3643-1
kde4libssourcewheezy4:4.8.4-4+deb7u2mediumDLA-570-1

Notes

The fix for 4:4.14.22-1 was incomplete, cf.
https://lists.debian.org/debian-lts/2016/07/msg00144.html
Fix: https://git.reviewboard.kde.org/r/128185/

Search for package or bug name: Reporting problems