CVE-2016-6250

NameCVE-2016-6250
DescriptionInteger overflow in the ISO9660 writer in libarchive before 3.2.1 allows remote attackers to cause a denial of service (application crash) or execute arbitrary code via vectors related to verifying filename lengths when writing an ISO9660 archive, which trigger a buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-554-1, DSA-3677-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libarchive (PTS)wheezy3.0.4-3+wheezy1vulnerable
wheezy (security)3.0.4-3+wheezy6+deb7u1fixed
jessie (security), jessie3.1.2-11+deb8u3fixed
stretch3.2.2-2fixed
buster, sid3.2.2-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libarchivesource(unstable)3.2.1-1low
libarchivesourcejessie3.1.2-11+deb8u3highDSA-3677-1
libarchivesourcewheezy3.0.4-3+wheezy2highDLA-554-1

Notes

https://github.com/libarchive/libarchive/issues/711
Fixed by: https://github.com/libarchive/libarchive/commit/3014e19820ea53c15c90f9d447ca3e668a0b76c6 (v3.2.1)
http://www.openwall.com/lists/oss-security/2016/07/20/1

Search for package or bug name: Reporting problems