CVE-2016-6263

NameCVE-2016-6263
DescriptionThe stringprep_utf8_nfkc_normalize function in lib/nfkc.c in libidn before 1.33 allows context-dependent attackers to cause a denial of service (out-of-bounds read and crash) via crafted UTF-8 data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-582-1, DSA-3658-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libidn (PTS)wheezy1.25-2vulnerable
wheezy (security)1.25-2+deb7u3fixed
jessie, jessie (security)1.29-1+deb8u2fixed
stretch1.33-1fixed
buster1.33-2fixed
sid1.33-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libidnsource(unstable)1.33-1medium
libidnsourcejessie1.29-1+deb8u2mediumDSA-3658-1
libidnsourcewheezy1.25-2+deb7u2mediumDLA-582-1

Notes

https://lists.gnu.org/archive/html/help-libidn/2016-07/msg00009.html
Test / Fix: http://git.savannah.gnu.org/cgit/libidn.git/commit/?id=1fbee57ef3c72db2206dd87e4162108b2f425555 (libidn-1-33)
http://www.openwall.com/lists/oss-security/2016/07/20/6

Search for package or bug name: Reporting problems