CVE-2016-6296

NameCVE-2016-6296
DescriptionInteger signedness error in the simplestring_addn function in simplestring.c in xmlrpc-epi through 0.54.2, as used in PHP before 5.5.38, 5.6.x before 5.6.24, and 7.x before 7.0.9, allows remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via a long first argument to the PHP xmlrpc_encode_request function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-569-1, DLA-628-1, DSA-3631-1
NVD severityhigh (attack range: remote)
Debian Bugs832959

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.22-3fixed
xmlrpc-epi (PTS)wheezy0.54.2-1vulnerable
wheezy (security)0.54.2-1+deb7u1fixed
jessie0.54.2-1.1vulnerable
buster, stretch, sid0.54.2-1.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.6.24+dfsg-1high
php5sourcejessie5.6.24+dfsg-0+deb8u1highDSA-3631-1
php5sourcewheezy5.4.45-0+deb7u5highDLA-628-1
php7.0source(unstable)7.0.9-1high
xmlrpc-episource(unstable)0.54.2-1.2high832959
xmlrpc-episourcewheezy0.54.2-1+deb7u1highDLA-569-1

Notes

PHP Bug: https://bugs.php.net/72606
http://git.php.net/?p=php-src.git;a=commit;h=e6c48213c22ed50b2b987b479fcc1ac709394caa
Fixed in 7.0.9, 5.6.24, 5.5.38
[jessie] - xmlrpc-epi <no-dsa> (Can be fixed via point release, nothing depending on it in stable)
In stretch/sid php7.0 is using the system library not the embedded one.

Search for package or bug name: Reporting problems