CVE-2016-6304

NameCVE-2016-6304
DescriptionMultiple memory leaks in t1_lib.c in OpenSSL before 1.0.1u, 1.0.2 before 1.0.2i, and 1.1.0 before 1.1.0a allow remote attackers to cause a denial of service (memory consumption) via large OCSP Status Request extensions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-637-1, DSA-3673-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)wheezy1.0.1e-2+deb7u20vulnerable
wheezy (security)1.0.1t-1+deb7u3fixed
jessie (security), jessie1.0.1t-1+deb8u7fixed
stretch (security), stretch1.1.0f-3+deb9u1fixed
buster, sid1.1.0g-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)1.0.2i-1high
opensslsourceexperimental1.1.0a-1high
opensslsourcejessie1.0.1t-1+deb8u4highDSA-3673-1
opensslsourcewheezy1.0.1t-1+deb7u1highDLA-637-1

Notes

https://www.openssl.org/news/secadv/20160922.txt
Fixed in 1.1.0a, 1.0.2i, 1.0.1u

Search for package or bug name: Reporting problems