CVE-2016-6323

NameCVE-2016-6323
DescriptionThe makecontext function in the GNU C Library (aka glibc or libc6) before 2.25 creates execution contexts incompatible with the unwinder on ARM EABI (32-bit) platforms, which might allow context-dependent attackers to cause a denial of service (hang), as demonstrated by applications compiled using gccgo, related to backtrace generation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs834752

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10fixed
wheezy (security)2.13-38+deb7u11fixed
glibc (PTS)jessie2.19-18+deb8u9fixed
jessie (security)2.19-18+deb8u3vulnerable
sid, stretch2.24-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)medium
eglibcsourcewheezy(not affected)
glibcsource(unstable)2.24-1medium834752
glibcsourcejessie2.19-18+deb8u6medium

Notes

[wheezy] - eglibc <not-affected> (Vulnerable code not present)
https://sourceware.org/bugzilla/show_bug.cgi?id=20435
https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=9e2ff6c9cc54c0b4402b8d49e4abe7000fde7617

Search for package or bug name: Reporting problems