CVE-2016-6337

NameCVE-2016-6337
DescriptionMediaWiki 1.27.x before 1.27.1 might allow remote attackers to bypass intended session access restrictions by leveraging a call to the UserGetRights function after Session::getAllowedUserRights.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)buster1:1.31.16-1+deb10u2fixed
buster (security)1:1.31.16-1+deb10u7fixed
bullseye1:1.35.13-1~deb11u1fixed
bullseye (security)1:1.35.13-1+deb11u2fixed
bookworm1:1.39.5-1~deb12u1fixed
bookworm (security)1:1.39.7-1~deb12u1fixed
sid, trixie1:1.39.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcewheezy(unfixed)end-of-life
mediawikisource(unstable)1:1.27.1-1

Notes

[wheezy] - mediawiki <end-of-life> (not supported in Wheezy LTS)
https://lists.wikimedia.org/pipermail/wikitech-l/2016-August/086342.html

Search for package or bug name: Reporting problems