DescriptionHeap-based buffer overflow in the yy_get_next_buffer function in Flex before 2.6.1 might allow context-dependent attackers to cause a denial of service or possibly execute arbitrary code via vectors involving num_to_read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3653-1, DSA-3653-2
NVD severityhigh (attack range: remote)
Debian Bugs832768

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flex (PTS)wheezy2.5.35-10.1fixed
jessie (security), jessie2.5.39-8+deb8u2fixed
buster, sid, stretch2.6.1-1.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flexsourcewheezy(not affected)


[wheezy] - flex <not-affected> (Issue introduced with 2.5.36)
Intorduced by: (flex-2-5-36)
Fixed by: (v2.6.1)

Search for package or bug name: Reporting problems