CVE-2016-6506

NameCVE-2016-6506
Descriptionepan/dissectors/packet-wsp.c in the WSP dissector in Wireshark 1.12.x before 1.12.13 and 2.x before 2.0.5 allows remote attackers to cause a denial of service (infinite loop) via a crafted packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-595-1, DSA-3648-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy1.8.2-5wheezy18vulnerable
wheezy (security)1.12.1+g01b65bf-4+deb8u6~deb7u7fixed
jessie1.12.1+g01b65bf-4+deb8u11fixed
jessie (security)1.12.1+g01b65bf-4+deb8u12fixed
stretch2.2.6+g32dac6a-2fixed
stretch (security)2.2.6+g32dac6a-2+deb9u1fixed
buster, sid2.4.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.0.5+ga3be9c6-1medium
wiresharksourcejessie1.12.1+g01b65bf-4+deb8u8mediumDSA-3648-1
wiresharksourcewheezy1.12.1+g01b65bf-4+deb8u6~deb7u3mediumDLA-595-1

Notes

https://www.wireshark.org/security/wnpa-sec-2016-42.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=12594
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=a9d5256890c9189c7461bfce6ed6edce5d861499
Affects 2.0.0 to 2.0.4, 1.12.0 to 1.12.12 , fixed in 2.0.5, 1.12.13
http://www.openwall.com/lists/oss-security/2016/07/28/3

Search for package or bug name: Reporting problems