CVE-2016-6711

NameCVE-2016-6711
DescriptionA remote denial of service vulnerability in libvpx in Mediaserver in Android 4.x before 4.4.4, 5.0.x before 5.0.2, 5.1.x before 5.1.1, and 6.x before 2016-11-01 could enable an attacker to use a specially crafted file to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service. Android ID: A-30593765.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvpx (PTS)wheezy1.1.0-1vulnerable
jessie1.3.0-3vulnerable
stretch, buster, sid1.6.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvpxsource(unstable)1.6.1-1high

Notes

[wheezy] - libvpx <no-dsa> (Minor issue)
probably fixed earlier, but this was the version checked
Wheezy is confirmed (by code inspection) to have vulnerable source.
https://android.googlesource.com/platform/external/libvpx/+/063be1485e0099bc81ace3a08b0ec9186dcad693

Search for package or bug name: Reporting problems