DescriptionA remote denial of service vulnerability in libvpx in Mediaserver in Android 4.x before 4.4.4, 5.0.x before 5.0.2, 5.1.x before 5.1.1, and 6.x before 2016-11-01 could enable an attacker to use a specially crafted file to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service. Android ID: A-30593765.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvpx (PTS)stretch (security), stretch1.6.1-3+deb9u2fixed
buster, buster (security)1.7.0-3+deb10u1fixed
bullseye, sid1.8.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[jessie] - libvpx <ignored> (Minpr issue)
[wheezy] - libvpx <no-dsa> (Minor issue)
probably fixed earlier, but this was the version checked
Wheezy is confirmed (by code inspection) to have vulnerable source.

Search for package or bug name: Reporting problems