CVE-2016-6801

NameCVE-2016-6801
DescriptionCross-site request forgery (CSRF) vulnerability in the CSRF content-type check in Jackrabbit-Webdav in Apache Jackrabbit 2.4.x before 2.4.6, 2.6.x before 2.6.6, 2.8.x before 2.8.3, 2.10.x before 2.10.4, 2.12.x before 2.12.4, and 2.13.x before 2.13.3 allows remote attackers to hijack the authentication of unspecified victims for requests that create a resource via an HTTP POST request with a (1) missing or (2) crafted Content-Type header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-629-1, DSA-3679-1
NVD severitymedium (attack range: remote)
Debian Bugs838204

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jackrabbit (PTS)wheezy2.3.6-1+deb7u1vulnerable
wheezy (security)2.3.6-1+deb7u2fixed
jessie (security), jessie2.3.6-1+deb8u2fixed
stretch2.12.6-1fixed
buster, sid2.14.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jackrabbitsource(unstable)2.12.4-1medium838204
jackrabbitsourcejessie2.3.6-1+deb8u2mediumDSA-3679-1
jackrabbitsourcewheezy2.3.6-1+deb7u2mediumDLA-629-1

Notes

http://svn.apache.org/r1758791 (2.4.x)
http://svn.apache.org/r1758771 (2.6.x)
http://svn.apache.org/r1758764 (2.8.x)

Search for package or bug name: Reporting problems