CVE-2016-6810

NameCVE-2016-6810
DescriptionIn Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
activemq (PTS)wheezy5.6.0+dfsg-1+deb7u2vulnerable
wheezy (security)5.6.0+dfsg-1+deb7u3vulnerable
jessie5.6.0+dfsg1-4+deb8u3vulnerable
jessie (security)5.6.0+dfsg1-4+deb8u2vulnerable
stretch5.14.3-3fixed
buster, sid5.15.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
activemqsource(unstable)5.14.2+dfsg-1unimportant

Notes

Admin console not enabled in the Debian package, see #702670
http://activemq.apache.org/security-advisories.data/CVE-2016-6810-announcement.txt
http://jvndb.jvn.jp/en/contents/2016/JVNDB-2016-000245.html
https://jvn.jp/en/jp/JVN78980598/index.html

Search for package or bug name: Reporting problems