CVE-2016-6893

NameCVE-2016-6893
DescriptionCross-site request forgery (CSRF) vulnerability in the user options page in GNU Mailman 2.1.x before 2.1.23 allows remote attackers to hijack the authentication of arbitrary users for requests that modify an option, as demonstrated by gaining access to the credentials of a victim's account.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-608-1, DSA-3668-1
NVD severitymedium (attack range: remote)
Debian Bugs835970

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mailman (PTS)wheezy1:2.1.15-1+deb7u1vulnerable
wheezy (security)1:2.1.15-1+deb7u2fixed
jessie (security), jessie1:2.1.18-2+deb8u1fixed
stretch1:2.1.23-1+deb9u1fixed
buster, sid1:2.1.24-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mailmansource(unstable)1:2.1.23-1medium835970
mailmansourcejessie1:2.1.18-2+deb8u1mediumDSA-3668-1
mailmansourcewheezy1:2.1.15-1+deb7u2mediumDLA-608-1

Notes

https://mail.python.org/pipermail/mailman-announce/2016-August/000225.html
https://bugs.launchpad.net/mailman/+bug/1614841
https://mail.python.org/pipermail/mailman-announce/2016-August/000226.html

Search for package or bug name: Reporting problems