CVE-2016-6906

NameCVE-2016-6906
DescriptionThe read_image_tga function in gd_tga.c in the GD Graphics Library (aka libgd) before 2.2.4 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file, related to the decompression buffer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3777-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2fixed
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie2.1.0-5+deb8u9fixed
jessie (security)2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster2.2.5-3fixed
sid2.2.5-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.4-1medium
libgd2sourcejessie2.1.0-5+deb8u9mediumDSA-3777-1
libgd2sourcewheezy(not affected)

Notes

[wheezy] - libgd2 <not-affected> (Vulnerable code introduced later)
Fixed by: https://github.com/libgd/libgd/commit/fb0e0cce0b9f25389ab56604c3547351617e1415
Fixed by: https://github.com/libgd/libgd/commit/58b6dde319c301b0eae27d12e2a659e067d80558

Search for package or bug name: Reporting problems