CVE-2016-6912

NameCVE-2016-6912
DescriptionDouble free vulnerability in the gdImageWebPtr function in the GD Graphics Library (aka libgd) before 2.2.4 allows remote attackers to have unspecified impact via large width and height values.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3777-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2fixed
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie2.1.0-5+deb8u9fixed
jessie (security)2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster2.2.5-3fixed
sid2.2.5-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.4-1high
libgd2sourcejessie2.1.0-5+deb8u9highDSA-3777-1
libgd2sourcewheezy(not affected)

Notes

[wheezy] - libgd2 <not-affected> (Vulnerable code introduced later)
https://github.com/libgd/libgd/commit/a49feeae76d41959d85ee733925a4cf40bac61b2

Search for package or bug name: Reporting problems