CVE-2016-7035

NameCVE-2016-7035
DescriptionAn authorization flaw was found in Pacemaker before 1.1.16, where it did not properly guard its IPC interface. An attacker with an unprivileged account on a Pacemaker node could use this flaw to, for example, force the Local Resource Manager daemon to execute a script as root and thereby gain root access on the machine.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs843041

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pacemaker (PTS)stretch1.1.16-1fixed
stretch (security)1.1.24-0+deb9u1fixed
buster, buster (security)2.0.1-5+deb10u1fixed
bullseye2.0.5-2fixed
bookworm2.1.1-2fixed
sid2.1.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pacemakersourcewheezy(not affected)
pacemakersource(unstable)1.1.15-3843041

Notes

[wheezy] - pacemaker <not-affected> (Vulnerable code introduced later)
https://github.com/ClusterLabs/pacemaker/pull/1166/commits/5a20855d6054ebaae590c09262b328d957cc1fc2

Search for package or bug name: Reporting problems