CVE-2016-7054

NameCVE-2016-7054
DescriptionIn OpenSSL 1.1.0 before 1.1.0c, TLS connections using *-CHACHA20-POLY1305 ciphersuites are susceptible to a DoS attack by corrupting larger payloads. This can result in an OpenSSL crash. This issue is not considered to be exploitable beyond a DoS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)jessie1.0.1t-1+deb8u8fixed
jessie (security)1.0.1t-1+deb8u10fixed
stretch1.1.0f-3+deb9u2fixed
stretch (security)1.1.0j-1~deb9u1fixed
buster, sid1.1.1a-1fixed
openssl1.0 (PTS)stretch (security), stretch1.0.2l-2+deb9u3fixed
buster, sid1.0.2q-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)1.1.0c-1medium
opensslsourcejessie(not affected)
opensslsourcewheezy(not affected)
openssl1.0source(unstable)(not affected)

Notes

[jessie] - openssl <not-affected> (Only affects 1.1.0)
[wheezy] - openssl <not-affected> (Only affects 1.1.0)
- openssl1.0 <not-affected> (Only affects 1.1.0)
https://www.openssl.org/news/secadv/20161110.txt

Search for package or bug name: Reporting problems